Instructions for using the Muse Viewer

Postby astarck » Sat May 16, 2015 8:14 am

I followed the instructions in the help page for exporting to data to the Muse SDK tools. I tried to play the data, but two problems arise. First, the data either show up as flat lines only. Second, if I try to adjust the y-axis range, the lines just shoot up and out of the screen ever time. Can possibly you write more detailed instructions on how to view the data in the SDK?

Thank you for the great app.
astarck
 
Posts: 2
Joined: Wed May 13, 2015 4:51 pm

Re: Instructions for using the Muse Viewer

Postby James » Mon May 18, 2015 9:01 pm

To play back the muse data file, first run MuseLab.exe

Make sure "OSC" is selected in the main drop down in the top left.
On the "Incoming" tab, select UDP and enter "5000" for the port number.
Click the "Open Port" button. Note that nothing will happen!
This makes MuseLab listen on port UDP5000 for incoming data.

Next run Muse Player. This is most easily done from the command prompt, or use notepad to make a simple batch file (e.g. RunMuse.Bat)
Use the "-f" option first to specify the input file and then "-s" to direct the output stream.
The command will look like this:
Code: Select all
muse-player.exe -f musedata.muse -s osc.udp://localhost:5000


Now the file is streaming out to UDP port 5000.
Go back to MuseLab.
If your stream is working you will see message arriving in the "Incoming Messages" section below where you set the UDP port.

In the top left down select "Visualizers".
Press "New".
Select "Scrolling Line Graph" and press the "Finish" button.

Under the "Signals" tab put a checkbox next to all the data types you wish to display.
Select the "Settings" tab.

Change Max Amplitude to "1".
Change Min Amplitude to "-1".
Press Apply.

You will now see your data scrolling past.

To pause and rewind, select the "Time" tab.
Check "Override Master Time" to enable the settings.
You can now drag the "History" slider back and forth, or change the scroll speed to a negative number to go back through your data.

As a final note, if you still see any flat lines after setting the min/max values correctly, this means that during that time period the sensor likely lost contact with your head. I have found this is especially common for myself with the ear sensors, which loose contact momentarily when I smile.
User avatar
James
Site Admin
 
Posts: 52
Joined: Wed Jan 02, 2013 9:06 pm


Return to Help

cron